
TTWin 4 Quick Start Guide
TTWin 4 is the latest evolution of Turbosoft’s premier Terminal Emulation package - a fast, accurate, reliable and 
powerful connectivity tool for Windows operating systems. It is simple to operate with features designed to enhance the 
value and functionality of your applications. 

TTWin 4 has been created to satisfy the need for wide ranging emulation coverage in a single quality product.  
Whether you have one or more host platforms, TTWin 4 will allow access to multiple emulations, using different 
communications protocols, simultaneously. 

Additionally, TTWin 4’s configurability ensures that it can be tailored to comfortably suit any environment.  We believe 
that TTWin 4 ranks highly amongst the very best products of this kind.

TTWin 4 is compatible with the following operating systems:

>> Windows 11
>> Windows 10
>> Windows Server 2025
>> Windows Server 2022
>> Windows Server 2019
>> Windows Server 2016

 
Versions are available for both 32bit and 64bit environments.

About this guide

This guide is designed to provide enough information to allow software installation and setup and to enable you to start 
working with TTWin 4. It assumes familiarity with the version of Windows you are using.

If you require additional information please refer to the full TTWin 4 User Guide. This document is included with 
your TTWin 4 installation or is available as a separate download from www.ttwin.com/support-downloads. For further 
assistance please contact Turbosoft Support, full contact details are listed on the last page of this document.

All screenshots in this document are taken from Windows 11.

This Quick Start guide applies to TTWin Version 4.9 and above.

Host connectivity for Windows®

https://www.ttwin.com/support-downloads


Installing Your Software 
These steps will allow you to install TTWin on your machine, either on a stand-alone PC or Terminal Server 
environment.

Evaluation Software Limitations
If you have not purchased a license, you are welcome to use the evaluation license that comes with TTWin. The 
evaluation license is restricted to 30 days of usage. If you find this time limit inadequate for your evaluation purposes, 
please contact your reseller or Turbosoft directly.

TTWin can be easily converted into a licensed, unrestricted version without the need for re-installation simply by 
importing the appropriate license certificate. Information on licensing TTWin can be found on page ten and eleven.

Installing TTWin 

Step 1
The TTWin installation package is available as a download from http://www.ttwin.com. Ensure you have the correct 
version for your operating system and environment as separate 32bit and 64bit installation packages are available.
On your Windows PC, run the downloaded installation file.

Step 2
The Software License Agreement is displayed. Please read the License Agreement and check the box at the bottom of 
the tile noting your acceptance of the agreement to continue the installation process.

Step 3
You are prompted to select which user account(s) you wish to install TTWin for. Available choices are installation for 
every user on the computer or just for the current account. 

Step 4
You are prompted for a destination folder. This is where TTWin will be installed. To change the destination folder, 
click on the Browse... button. By default TTWin is installed in C:\Program Files\Turbosoft\TTWin4

Step 5
Select or create a start menu folder for TTWin.

Step 6
Accept the Setup Complete tile by clicking on the Finish button. Optionally, the program may be launched on 
exiting the installer. The new program group will be visible and a TTWin icon can be seen within the folder. 

You are now ready to begin working with TTWin.
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Getting Started with TTWin 
At this point all that remains to do is to configure a session and then connect to your host. Before you get started, 
however, there are a few pieces of information you need in order to complete a successful connection to a host system. 

Firstly, you need to know what sort of terminal you wish to emulate. Since TTWin supports such a wide range of 
emulations, you will need to know which one to choose in order to successfully interact with your host applications. 

Next, you need to know how you are going to communicate with the host system.  You will need to know what 
method of communications your host is expecting, as well as your host address and any settings that you require.  

This information, along with any particular settings that you require, should be available from your System 
Administrator. 

To start TTWin go to Start > All Programs > TTWin4 and select the TTWin 4 icon. Depending on your choices 
during installation, the program folder name may vary.

Configuring TTWin

When TTWin is started it loads a number of default settings from its default configuration file. TTWin’s default 
emulation is set to DEC VT220 and communications are set to Telnet. Once loaded TTWin will present a Telnet 
Connect tile and prompt for host details before initiating a VT220 session. Unless VT220 and Telnet are your required 
settings it is suggested that you select Cancel to dismiss the prompt and configure TTWin to suit your requirements. 

Settings can be modified to select your preferred emulation, communication, file transfer and session settings. The 
easiest way of doing this is via the configuration menu.  From the main menu select the Configure item as shown in 
figure 1. You will then be able to select the TTWin features that you wish to alter. 

Figure 1. Configuration menu option
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Step 1. Emulation Configuration
Firstly, we will select the type of terminal that you wish to use. From the Configure menu, choose the Emulation... 
item. This will display the Configure tile for the currently selected emulation as shown in figure 2. If the terminal 
that you wish to use is different from the one currently selected you can choose a new emulation by selecting the 
Change Terminal button.

Choose your desired emulation from the list presented to you, then press OK.

Check the settings for the emulation - in most cases the defaults will be fine. Note that some emulations have several 
models or types that are covered by one emulation module, for example the DEC VT series covers several terminal 
types including the VT100, the VT220, the VT420 and more. By changing the Terminal ID field shown in figure 2 
you can change the way the emulation communicates with the host. Ensure that you select the correct model for your 
host.

Once you are happy with your emulation settings select OK.

Figure 2. Configure Emulation tile (VT220 selected)
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Step 2. Communication Configuration
To change your Communications module select Configure > Comms... from the menu and you will be presented 
with the configuration tile for the current communications module as shown in figure 3. If you would like to use a 
different communications module, click the Change Comms button, then select the communications module from 
the list that is shown. 

Figure 3. Communications configuration

Once you have chosen your communications module, you will need to configure it so that it can ‘see’ your host. In 
most cases, such as Telnet and SSH, this will simply require the host name or IP Address to be entered. However, for 
some, such as the Serial communications, there are additional settings that you need to configure. Please use the Help 
button for more information on these settings. 

These setting may be entered on the configure tile (figure 3) or, if you wish, you may leave Telnet and SSH host 
settings blank and allow TTWin to prompt you for detail when you attempt to initialize a host connection.

Saving Your Settings 

Once you have selected your emulation and communication settings, be sure to save the configuration file for future 
use. From the menu, choose File > Save configuration or File > Save configuration as.... 

If you select Save Configuration your new settings will overwrite the currently loaded configuration file and become 
the new default. 

If you select Save Configuration As...., you will be prompted for a file name, and once this has been entered you 
can save the configuration file. By default, the configuration file will be given a .twc file extension and stored in the 
Turbosoft\TTWin4 directory in your user profile.
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Advanced Configuration 
This section outlines some of the more detailed TTWin configuration options which may prove useful during the 
evaluation period.

Re-mapping the Keyboard
Each emulation has its own preset key mappings and in most cases you will not need to alter the existing keyboard 
configuration. If you find that some of the keys are not working as required you should first check that you are 
using the correct emulation for your host environment. If you have loaded the correct emulation and your keyboard 
configuration still requires some fine tuning, follow these steps:

1	 Load the emulation you wish to map the keys for, see Emulation Configuration on page 4 for more detail.

2	 Select Configure > Keyboard... from the menu. This will display the Configure Keyboard tile shown in 
figure 4.

3	 Select a physical key from the PC Keyboard.

4	 Select any shift state you require. For example, if you want to map Ctrl+A, you will need to select ‘A’ from the 
PC Keyboard and then select Ctrl.

5	 Select the type of mapping you want, either Emulation Key or String. 

To map an Emulation Key:

	         >Select the Emulation Key radio button.

           >Select the required key from the Emulation keyboard 

           >If you cannot find the key on the emulation keyboard tick the Show list option and select the key 	

             from the list.  

To map a String:

            >Select the String radio button.

            >Enter the required string in the text box                  

Strings can contain plain text or macros. See page 7 for more information on macros. 

6	 Click the Map button to save the mapping.

If you wish to map another key, repeat the process from step 3.

7	 Select OK when finished mapping keys.

8	 Select File > Save configuration or File > Save configuration as.... to keep the mappings.
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Figure 4. Keyboard mapping, showing the physical F1 key mapped to the emulation PF1 key.

Macros
TTWin support several macro sequences that enable you to extend its functionality. These macros can be used in keyboard 
mappings, start up and connect strings. Most items that allow for the use of macros will have a macro assistant button (...) 
next to the string text box. Below is a list of commonly used macro sequences.

\n = Line Feed
\r = Carriage Return
\x = Uses the next two characters as an ASCII hex value, for example \x1b will send an Escape
\t = Tab
\b = Backspace
\f = Form Feed
\p = Uses the next three characters as time to pause in tenths of a second, \p010 will pause for one second
\\ = \
\{ = {
{KeyName} = Send the emulation key enclosed in the braces.
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Automating Login
There are several features within TTWin which can assist in automating tasks such as user login. The macro method 
outlined below is included for simplicity. Advanced users may wish to investigate the possibilities of TTWins built in 
scripting language TTWin Basic. To automate the login process, complete the following steps:

1	 From the menu select Configure > General... > Session Preferences 

2	 In the Connect string enter the login details follow by the emulation keys in braces, a pause at the 

beginning will give the host time to respond. For example

      \p010UserName{Return}\p010Password{Return}

The above string will pause for 1 second send the username, send the [Return] key, then pause for another 

second, send the Password, then send a second [Return] key. See figure 5 for more detail.

The name of the {Return} key may change depending on the emulation being used.

For the automated login to work, you MUST specify host details when configuring the 
communications settings. See page 5 for more detail.

3	 Select File > Save Configuration or File > Save Configuration As... to retain these settings.

Figure 5. Detail of the Preferences tile showing the Connect string field.
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Connecting
To initiate a connection, choose the Action > Connect menu function, or alternatively right mouse click on the 
display area of your TTWin session. This will activate a pop-up menu from which you can select the Connect option. 

If you have not applied a license to TTWin the program will be running in the default evaluation mode. Evaluation 
copies of TTWin are restricted to 30 days of usage, however they are fully functional in all other respects. When running 
in evaluation mode you will see a dialog each time you try to connect informing you of the time remaining before the 
evaluation license expires. To continue in evaluation mode, select OK.

Figure 6. Evaluation Notice

This will connect you to your host using the information that you supplied while configuring TTWin. If you did not 
enter any details that are required, such as telnet host name, you will be prompted for these before the connection takes 
place.

If you are using a serial connection via a modem, when you connect to your host you 
are actually connecting to a modem. You will then need to instruct the modem to dial 
and connect to the host. Please refer to the documentation supplied with your modem 
for the correct initialization string and command set.

If you are unable to connect, then please re-check your Communications and Emulations settings as outlined on pages 4 
and 5. In addition, please check that the host environment is correctly configured for you to connect. Should you still be 
unable to connect, please record as much detail as possible regarding your settings and contact Turbosoft Support. 

Now That You Are Connected...

Once you have a successful connection, you should be able to interact with your host as per the standard terminal that 
you chose to emulate. If the terminal does not appear to be behaving the way you are expecting it to, please re-check 
the settings in the Emulation configuration. In the unlikely event that you continue to have problems with your copy 
of TTWin, please contact Turbosoft Support. Contact details are listed on page 12 of this document.
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Disconnecting
Once you have completed your session on the host system, you will need to disconnect from the host. A TTWin 
session may be disconnected from the host computer in a number of different ways, usually as a result of the user 
logging out from the host computer. 

To manually disconnect select Actions > Disconnect from the menu. Once this action is performed TTWin will no 
longer be connected and the program can be closed.

Figure 7. Disconnecting.

Licensing TTWin 
When you purchase TTWin you will be issued with a license certificate. To enable your licensed copy of TTWin you can 
import your license certificate by starting the program and selecting Help > About... from the menu. Next, select the 
License tab, click the Import certificate button and load your certificate file (*.tcf).

You will see a message box stating “The license has been updated. This license needs to be activated”. Each time you start 
TTWin you will be informed that you need to activate the software. You have 7 days to complete this activation.

There are two activation methods: online (default) or manual activation.

Online Activation 

For this option to work TTWin needs to be able to connect to the internet.

1	 When prompted to activate TTWin select the Activate online option then click the Activate button.

TTWin will then connect to the Turbosoft Activation Server and automatically import a new certificate unique to the PC 
you are installing on. Your software is now activated.
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If you receive a connection error, please wait a moment and try again. If you continue 
to receive this message check if firewall or proxy server settings are preventing TTWin 
accessing the Activation servers. In this situation we recommend manual activation.

Manual Activation

If TTWin is unable to connect to the internet from the PC it is installed on you may activate your software using the 
manual activation process:

1	 Select the Save the request to a file option and click the Activate button.

2	 Save the resulting ttact.xml file

3	 Copy this file to a PC that has internet access.

4	 Open a browser to https://mercury.ttwin.com/request

5	 Fill out the activation form selecting the ttact.xml from your local PC.

6	 Optionally, enter an email address where you would like the new activated certificate to be sent.

7	 Select the Retrieve Certificate File button.

You will then be presented with a link to download a new certificate file and, if you chose to enter an email address, the file 
will also be sent to you via email. Transfer this file to the PC containing your TTWin installation and do the following:

1	 Start TTWin and select Help > About... 

2	 Select the License tab, click the Import certificate button and load your new certificate file.

3	 Restart TTWin.
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Support and Further Information 
FAQ’s, full user manuals and other support resources are available from the support section of www.ttwin.com (free 
registration required for downloads). You may also wish to contact Turbosoft’s support staff - full support is extended 
to users evaluating Turbosoft products. 

To raise an issue with Turbosoft support visit www.ttwin.com/support. When describing your issue be sure to include 
information on the exact version of the Turbosoft product you are using. This information can be obtained by selecting 
Help > About > Version from the program menu.

Scripting

TTWin 4 features a powerful scripting language, similar in syntax to Visual BASIC for Applications (VBA). This greatly 
simplifies the process of learning without compromising flexibility or functionality. The release of TTWin version 4.8 
saw a number of changes to our in-program scripting including language changes and the addition of a new Integrated 
Development Environment (IDE) featuring syntax highlighting, auto-complete and debugger. 

With scripting the advanced user can perform complex processing on all data whether it appears on the screen, is entered 
by the user or appears in the data stream. In this way it is possible to greatly enhance legacy applications with dialogue 
boxes, scroll regions, automatic reformatting of data and much more. These represent only a few of the many possibilities.

A scripting QuickStart guide including samples is available from the support download section of www.ttwin.com and 
further documentation is also available through in-program help.

Contact Details
Website:

www.ttwin.com

Email:

sales@ttwin.com
support@ttwin.com

Telephone:

Australia: (02) 9191 9270 
North America Toll Free:  833 432 3291
United Kingdom: (020) 3423 5708

International:  +61 2 9191 9270

https://www.ttwin.com
https://www.ttwin.com/support
https://www.ttwin.com

