
TTerm For Linux Quick Start Guide
TTerm for Linux is Turbosoft’s high quality terminal emulation software for Linux operating systems offering users a 
high degree of configurability, session control, screen enhancing capabilities, productivity tools and the widest range of 
terminal coverage.

TTerm for Linux has been created to satisfy the need for wide ranging emulation coverage in a single quality product.  
Whether you have one or more host platforms, TTerm for Linux will allow access to multiple emulations, using differ-
ent communications protocols, simultaneously. 

TTerm for Linux is a 64bit application which is supported for Ubuntu, SUSE and OpenSUSE, CentOS and Red Hat 
distributions.

About this guide

This guide is designed to provide enough information to allow software installation and setup and to enable you to start 
working with TTerm for Linux. It assumes familiarity with the distribution of Linux you are using.

If you require additional information please refer to the full TTerm for Linux User Guide. This document is included 
with your TTerm for Linux installation. For further assistance please contact Turbosoft Support, full contact details are 
listed on the last page of this document.

All screenshots in this document are taken from OpenSUSE 42.3.

This Quick Start guide applies to TTerm for Linux 1.2.2 and above.

Host connectivity for Linux®



Installing Your Software 
The following steps will allow you to install TTerm for Linux on your device.

System Requirements

TTerm for Linux supports the following 64 bit distributions:

>> Ubuntu 16+
>> Red Hat 7+
>> CentOS 7+
>> Suse 12 SP2+
>> OpenSuse 42+

Other distributions are available on request..

Hardware Requirements

>> Approximately 50MB of free disk space.
>> A network connection.

Installing TTerm for Linux 

The TTerm for Linux installation package is available as a download from https://www.ttwin.com. Ensure you have the 
correct version for your distributions package manager. TTerm for Linux is available as a .deb file (for Ubuntu) or an 
.rpm (for SUSE, OpenSUSE, Red Hat and CentOS).

With the appropriate user permissions install the software:

SUSE/OpenSUSE/CentOS/Red Hat

1	 	Run sudo rpm -i TTermForLinux-Dist-x.x-x.x86_64.rpm

2	 	You will find the TTerm for Linux shortcut in the Internet section of your applications menu. 

3	 	You are now ready to begin working with TTerm for Linux. 

Ubuntu

1	 	Run sudo dpkg -i TTermForLinux-x.x.x.x-Dist_amd64.deb

1	 	You will find the TTerm for Linux shortcut in the Internet section of your applications menu. 

2	 	You are now ready to begin working with TTerm for Linux. 
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Evaluation Software Limitations
If you have not purchased a license, you are welcome to use the evaluation license that comes with TTerm for Linux. 
The evaluation license is restricted to 30 days of usage. If you find this time limit inadequate for your evaluation pur-
poses please contact your reseller or Turbosoft directly.

TTerm for Linux can be easily converted into a licensed, unrestricted version without the need for re-installation sim-
ply by importing the appropriate license certificate. 

Information on licensing TTerm for Linux can be found on page 14. 

Uninstalling TTerm for Linux 

SUSE/OpenSUSE/CentOS/Red Hat

To uninstall TTerm for Linux you should follow the standard software uninstallation process for your operating system. 
For example rpm -qa | grep TTermForLinux | xargs sudo rpm -e

Ubuntu

To uninstall TTerm for Linux you should follow the standard software uninstallation process for your operating system. 
For example sudo dpkg –-remove ttermforlinux
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Getting Started with TTerm for Linux 
To intiate a host connection you will first need to configure a profile.

TTerm for Linux defines a profile a as set of configuration options that is used to gener-
ate a session to a host. When the TTerm for Linux application is opened it will display 
the Profile Directory, a list of all available saved profile configurations.

Before getting started there are a few pieces of information needed in order to create the profile.  Firstly, you need to 
know what sort of terminal you wish to emulate. TTerm for Linux supports numerous emulations and you will need to 
know which one to choose in order to successfully interact with your host applications. 

Next, you need to know how you are going to communicate with the host system. You will need to know what method 
of communications your host is expecting, as well as your host address (either a hostname or IP number) 

This information, along with any other specific settings that you require, should be available from your System 
Administrator. 

Launch TTerm for Linux from your desktop environment menu. Typically you will find the TTerm for Linux shortcut 
in the Internet section of your Applications menu. 

Configuring TTerm for Linux

When the TTerm for Linux application is opened it will display the Profile Directory, a list of all available saved pro-
file configurations. On installation this will be limited to a single, preconfigured profile titled Default.

The Default profile may be edited or duplicated but it may not be deleted. When creating a new profile, it is used as a 
template and its settings are copied across to the new profile. 

If you are planning to create multiple profiles, each with only minor variations, it may be 
useful to edit the Default profile for use as a template.

To create a new profile click the Create New Profile button at the bottom of the Profile Directory as shown in 
Figure 1 (following page). 

This will create a new profile prefilled with settings from the Default profile. 

Click the Open for Editing button on the tile that appears to open the Profile Editor. Access to configuration 
options such as Keyboard Mapping, Color Configuration and others are available from the Profile Editor. 
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Figure 1. The Profile Directory, showing the default profile.

Step 1. Emulation Configuration

Firstly, select the type of terminal that you wish to use. The Default profile is configured to use a VT220 emulation. 
To switch to a different emulation select the Edit button on the Emulation summary field as shown in Figure 2 or 
simply click Emulation from the left column of the Profile Editor.  

Figure 2. Emulation Configuration 
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Figure 3. Emulation Configuration 

Choose the desired emulation from the list presented at Select Emulation.

Upon selecting a different emulation TTerm for Linux will display a new set of configuration options specific to the 
selected terminal below.  Check these emulation settings - in most cases the defaults will be fine. 

Note that some emulations have several models or terminal types that are covered by one emulation module, for 
example the DEC VT series covers several terminal types including the VT100, the VT220, the VT420 and more. By 
changing the Terminal ID option you can change the way the emulation communicates with the host. Ensure that you 
select the correct model for your host.

Step 2. Communication Configuration

The communications module may be modified in a similar manner to the emulation either by selecting 
Communications from the left column of the Profile Editor or clicking the Edit button in the communications 
summary field. 

If you would like to use a different communications module to the default selection, select from the list that is shown 
at Select Communications as shown in Figure 4.
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Figure 4. Communications Configuration

Once you have chosen your communications type, you will need to configure it so that TTerm for Linux can address your 
host system.

The Remote Host Address field defines the host name or IP address of the system the profile will attempt to connect to. 
If left blank, by default TTerm for Linux will prompt for host details when a connection attempt is made.

TTerm for Linux offers a wide range of configuration options for accurate terminal emulation, however in many cases the 
default options are suitable and you may not need to edit outside the basic settings denoting host address, communications 
transport and emulation type. For more detail on emulation and communications configuration options refer to the TTerm 
for Linux User Guide.

Saving Your Settings 

Once the required emulation and communication settings are selected, be sure to save the profile configuration for future 
use. Select Save to finish editing or Save and Connect to retain the profile settings and connect to the host immediately.
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Advanced Configuration 

This section outlines some of the more advanced TTerm for Linux configuration options, for more detailed informa-
tion on the topics covered please refer to the TTerm for Linux User Guide.

Keyboard Mapping

Each emulation has its own preset Default keyboard mapping and in most cases you will not need to alter the existing 
keyboard configuration. If you find that some of the keys are not working as required you should first check that you 
are using the correct emulation for your host environment. If you have loaded the correct emulation and your keyboard 
configuration still requires some fine tuning follow these steps:

To configure keyboard mapping select Configure > Edit Current Profile from the program menu or, from the 
Profile Directory, selecting More > Edit on the profile of your choice. 

Select Keyboard Mapping from the Profile Editor. Configuration options will be displayed as shown in Figure 5.

Figure 5. Keyboard mapping in the Profile Editor.

Selecting a Keyboard Map

The Default keyboard mapping for each emulation is read only and cannot be edited. To change a keymapping you 
will need to either select an existing alternate mapping from the list available at Select a Keyboard Map or create a 
new map set.
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To create a new Keyboard Map: 

1	 Select the New button, this will create a new key template based on the default key set for the selected emulation.

2	 Edit the Name and Description in the Keyboard Mapping Settings section as required.

To copy an existing Keyboard Map: 

3	 Select an existing set you would like to copy from the Select a Keyboard Map drop down list.

4	 Select the Duplicate button, this will create a new key template based on the selected key set.

5	 Edit the Name and Description in the Keyboard Mapping Settings section as required.

Mapping Physical Keys

You can create mappings for physical keys by mapping to:

>> An emulation key from the current emulation, e.g., the VT220 PF1 key. 
>> An emulation specific escape sequence, string or macro.

To map an emulation key or emulation string to a physical key or key sequence, follow these steps:

You can use the [SHIFT], [ALT] and [CTRL] keys together with a physical key, if 
required.

1	 Select Configure > Edit Current Profile from the program menu or, from the Profile Directory, selecting 
More > Edit on the profile of your choice. 

2	 Select Keyboard Mapping from the Profile Editor. Configuration options will be displayed as shown in 
Figure 6 (following page).

3	 Select the physical key you wish to map from the PC Keyboard list. The emulation key, or the string/macro 
currently mapped to that selected physical key will be highlighted and displayed at the top of the Emulation 
Keyboard section.

4	 Select a option from the Map Key selection list:
>> Emulation key, go to step 5.
>> String, go to step 6.

5	 Emulation key: Select the emulation key you want to assign to the selected physical key. 

6	 String: You can assign an ASCII data string, an escape sequence or a macro to the physical key. Enter the string 
or macro in the text box. Click the Assist button to open the Macro Assistant.

7	 To save the mapping, click on the Map Key button. 

8	 Repeat the above steps for all the physical keys you need to map. 
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9	 To save session settings you must also save the profile by selecting Save or Save and Connect.

For example, to map the ANSI BOLD escape sequence (ESC[1m) to [CTRL_F6] for the current emulation, follow 
these steps:

1	 Click on the [CTRL] check box and the [F6] key on the PC keyboard list.

2	 Select String/Macro. 

3	 In the text field enter the string: \x1b[1m where \x1b represents the hex value for ESCAPE character. 

Hex values are prefixed by \x

4	 Click on the Map Key button to save the mapping. 

5	 To finish editing the profile and retain settings select Save or Save and Connect.

.

Figure 6. Mapping a key, in this case a physical F4 + Control key is mapped to the emulation PF4 key.

Removing a Mapping

Click on the Remove Mapping button to remove a mapping. Alternatively, re-map BOTH the physical key(s) and the 
emulation key(s).
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Macros

TTerm for Linux supports macro sequences that enable you to extend its functionality. Macros can be used in many 
places, particularly keyboard mappings, start up and connect strings. Below is a list commonly used macro sequences.

\n = Line Feed

\r = Carriage Return

\x = Uses the next 2 characters as a ASCII hex value, for example \x1b will send an Escape

\t = Tab

\b = Backspace

\p = Uses the next 3 characters as time to pause in tenths of a second, \p010 will pause for 1 second

\\ = \

{KeyName} = Send the emulation key enclosed in the braces.

Where a macro can be added as a configuration option you will also see an Assist button next to the configuration item. 
Clicking this button will launch the Macro Assistant, a tool which enables Macros to be built through a graphic inter-
face, greatly simplifying the creation of complex macros for automating tasks.

.

Figure 7.  TTerm for Linux Macro Assistant tile.
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Automating Login

The are a number of features within TTerm for Linux which can assist in automating tasks such as user login. The 
macro method outlined below is included for simplicity. To automate the login process complete the following steps:

1	 Select Configure > Edit Current Profile from the program menu or, from the Profile Directory, selecting 
More > Edit on the profile of your choice

2	 Select General from the Profile Editor.

3	 In the Connect Macro item enter the login details follow by the emulation keys in braces, a pause at the 
beginning will give the host time to respond. For example:

\p010UserName{Return}\p010Password{Return}

The above macro will pause for 1 second send the username, send the [Return] key, then pause for another 

second, send the Password, then send a second [Return] key. 

The name of the {Return} key may change depending on the emulation being used.

4	 Click Save to retain these settings.
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Connecting
To initiate a connection select the Profiles Directory tab (if the Profiles Directory is hidden, make it visible by 
selecting View > Profile Directory from the program menu) and click the Connect button alongside the desired 
profile. 

Alternately, whilst viewing an open session tab select the Action > Connect menu function on the desired session tab 
or click the connect icon from the program toolbar. 

If you have not applied a license to TTerm for Linux the program will be running in the default evaluation mode. 
Evaluation copies of TTerm for Linux are restricted to 30 days of usage, however they are fully functional in all other 
respects. When running in evaluation mode you will see a dialog each time you try to connect informing you of the time 
remaining before the evaluation license expires. To continue in evaluation mode select OK.

Any one of these methods will connect you to a host using the information supplied in the profile. If you did not enter  
details that are required, such as a host name, you may be prompted for these before the connection takes place.

If you are unable to connect, then please re-check your Communications and Emulations settings as outlined on page 5 
and page 6. In addition, please check that the host environment is correctly configured for you to connect. Should you 
still be unable to connect, please record as much detail as possible regarding your settings and contact Turbosoft Support. 

Now That You’re Connected...

Once you have a successful connection, you should be able to interact with your host as per the standard terminal that 
you chose to emulate. If the terminal does not appear to be behaving the way you are expecting it to, please re-check 
your Emulation configuration. In the unlikely event that you continue to have problems with your copy of TTerm for 
Linux, please contact Turbosoft Support. Contact details are listed on page 16 of this document.

Disconnecting
A TTerm for Linux session may be disconnected from the host computer in a number of different ways, usually as a 
result of the user logging out from the host computer. 

To manually disconnect, you may select the Action > Disconnect function from the TTerm for Linux menu as 
shown in Figure 8 or click the disconnect icon from the program toolbar.

Figure 8. Disconnecting using the Actions > Disconnect menu option. 
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Licensing TTerm for Linux
Licensing TTerm for Linux is a two step process, uploading a license certificate and then activating that certificate. 

A license certificate is provided by Turbosoft or a Turbosoft distributor in the form of a .key file. If you do not have a 
license file but have purchased TTerm for Linux please contact your Turbosoft representative to obtain your license file.

To import the license select Help > About from the program menu and select the License tab. Click the Upload 
License button and locate your license file.

Once successfully imported TTerm for Linux will attempt to activate the license automatically.

License Activation

License activation is a one time process which stamps a license certificate with a unique identifier and completes the 
licensing process. There are two activation methods, in program activation (online) or manual activation (offline). 

In Program Activation

In Program Activation of a license is the default method and is an automated, transparent process. 

When a license file is added to TTerm for Linux the program will attempt to automatically submit the file to the 
Turbosoft license servers where it will be stamped and returned to the installation. Once the license is activated TTerm 
for Linux will be fully licensed and functional.

In situations where a TTerm for Linux installation has limited or no access to external networks In Program Activation 
will not be possible as TTerm for Linux will not be able to directly communication with the Turbosoft license servers. 

In such a scenario TTerm for Linux will report the license activation as incomplete and offer manual activation as 
shown in Figure 9 (following page.)

Manual Activation

Where an In Program Activation attempt has failed TTerm for Linux will provide an intermediate license file (.act). 
Manually activating a license requires downloading this file and then uploading it to a Turbosoft web page from a 
device that does have internet access. The file will then be processed and returned for upload back into TTerm for 
Linux.

When a valid license has been uploaded into TTerm for Linux but has not yet been activated TTerm for Linux will 
function in a fully licensed state for a grace period of seven (7) days. During this time the activation must be completed 
or TTerm for Linux will revert to an unlicensed state. 
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.

Figure 9. To manually activate TTerm for Linux, download an .act file.

To manually activate TTerm for Linux follow these steps:

1	 Click Download .act (Offline Activation) to retrieve an .act  file as shown in Figure 9.

2	 Save the resulting .act file.

3	 Copy this file to a computer or device that has internet access.

4	 Open a browser to https://mercury.ttwin.com/ttermforlinux

5	 Fill out the activation form selecting the .act from the local device. Once completed the form will return a 
direct link to download the activated license file, optionally, enter an email address where the newly activated 
certificate will also be sent.

6	 Select the Retrieve Certificate File button to submit the activation form. 

A link will then be presented which will download a new .key certificate file and, if email details were entered in step 
5, the file will also be sent to the nominated email address. 

Transfer the file to the device running TTerm for Linux to complete the process.

1	 Start TTerm for Linux and select Help > About from the program menu. 

2	 Select the License tab, click the Upload License button and locate the activated .key file.

The license file details will be loaded into TTerm for Linux and display as valid. TTerm for Linux is now licensed and 
fully functional.

https://mercury.ttwin.com/ttermforlinux.php
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Support and Further Information 
FAQ’s, full user manuals and other support resources are available from the support section of  www.ttwin.com. You 
may also wish to contact Turbosoft’s support staff - full support is extended to users evaluating Turbosoft products. 

To raise an issue with Turbosoft support visit https://www.ttwin.com/support. When describing your issue be sure to 
include information on the exact version of the Turbosoft product your are using. This information can be obtained by 
selecting Help > About > Version from the program menu.

Contact Details
Website:

www.ttwin.com

Email:

sales@ttwincom
support@ttwin.com

Telephone:

Australia: (02) 9191 9270 
North America Toll Free:  833 432 3291
United Kingdom: (020) 3423 5708

International:  +61 2 9191 9270


